VyprVPN Setup Guide for Android TV

As of VyprVPN version 2.10, our Android app supports Android TV devices and most other Android boxes such as Google TV. It is also compatible with many third-party Android boxes from various manufacturers. These devices need to be running the most current version of Android for the device, preferably Android 4.0.3 Kit Kat and higher.

You can download the app via the Play store, or download the APK here for side-loading.

This is not an exhaustive list of compatible devices, but we have confirmed the following devices are working through extensive testing:

  • Nexus Player (Running Lollipop and Marshmallow)
  • Matricom G-Box running 4.4.2 Kit Kat
  • ShufTV running 4.4.4 Kit Kat 

If you need any further assistance, please contact support.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request